False status

Discussion in 'Bug Reports' started by Akmal, Jul 6, 2015.

  1. Akmal

    Akmal New Member

    Dear Mr. Mun,
    Thanks for a great server monitoring. I'm monitoring for 5 server, but, one server always showing down while it actually up. What wrong with that server?

    Thank you.
     
  2. Mun

    Mun Administrator

    Can you link me to your status page, you can PM me if you like.
    (however)
    Most likely the issue is your server has a bad network / peering or the monitoring server has a bad connection to that server. ServerStatus isn't perfect in that sense as it doesn't have multiple probes (yet).


    To get clearer details on why you server may be showing down I suggest you install the network tool mtr. (debian instructions below)
    Code:
    apt-get update && apt-get install mtr-tiny
    mtr your.server.com
    
    It should return something like this:
    Code:
    mtr google.com --report
    Start: Mon Jul  6 15:58:07 2015
    HOST: Cameron-233-191             Loss%   Snt   Last   Avg  Best  Wrst StDev
      1.|-- 192.168.226.250            0.0%    10    0.5   0.7   0.5   2.1   0.3
      2.|-- 192.168.2.1                0.0%    10    0.2   0.2   0.2   0.4   0.0
      3.|-- 207.62.28.249              0.0%    10    2.1   2.3   1.9   4.3   0.5
      4.|-- 198.188.249.18             0.0%    10    1.7   1.7   1.7   1.8   0.0
      5.|-- dc-slo-dc1--slocoe-ge.cen  0.0%    10    1.9   1.9   1.8   2.0   0.0
      6.|-- dc-sol-agg2--slo-agg1-10g  0.0%    10    4.2   4.1   4.1   4.2   0.0
      7.|-- dc-sol-agg1--sol-agg2-10g  0.0%    10    4.1   4.1   4.1   4.2   0.0
      8.|-- dc-svl-agg4--sol-agg1-10g  0.0%    10   10.7  10.7  10.6  10.9   0.0
      9.|-- 72.14.242.90               0.0%    10   11.0  11.0  10.9  11.0   0.0
     10.|-- 216.239.49.250             0.0%    10   11.5  13.2  11.3  25.4   4.4
     11.|-- 209.85.246.253             0.0%    10   11.5  11.5  11.3  11.5   0.0
     12.|-- 64.233.174.206             0.0%    10   10.9  11.0  10.9  11.2   0.0
     13.|-- 64.233.174.189             0.0%    10   11.2  11.1  11.0  11.5   0.0
     14.|-- 209.85.250.245             0.0%    10   11.4  11.4  11.2  11.5   0.0
     15.|-- lax02s19-in-f8.1e100.net   0.0%    10   11.0  11.0  10.9  11.1   0.0
    
    
    As you can see there is a "Loss%" which would indicate a percentage of lost packets to your server from what ever server you are using to monitor.
     
  3. Akmal

    Akmal New Member

    No loss packets in my mtr. Link page status was in PM.

    Thanks for quick reply.
     
    Last edited: Jul 6, 2015
  4. Mun

    Mun Administrator

    After looking further, everything looks good on the uptime page, though you have modified it.

    Can you double check your address that you are pulling with.

    Open /yourpath/includes/config.php
    Look for the server that is misbehaving.
    Copy the 'url' => 'this_section_here'
    and then do a wget test to make sure you are getting the file.
    Code:
    wget this_section_here
    
    If you could PM me the results it would be much appreciated.

    Mun
     
  5. Akmal

    Akmal New Member

    Result in PM.
    Yeah. I want to add more features in this app. Some of them is to monitoring max mysql connections usage and notify me when reach at certain critical amount. I'm trying to use google smtp instead internal mail server right now.

    Thank you
    Akmal
     
  6. Mun

    Mun Administrator

    Sent a PM asking for more info.
     
  7. Akmal

    Akmal New Member

    Problem solved when I increased 'timeout' to 70 (/pull/index.php line 179). Is not to high?
     
  8. Mun

    Mun Administrator

    It shouldn't be too bad, but realize it will wait that full 70 seconds during a fail will likely timeout in apache first causing no error to be thrown. Try maybe 15 to 30 instead.

    It does however look like a server bug related to pulling from the same host, however I have never been able to replicate the issue during testing.
     
  9. Akmal

    Akmal New Member

    I tried to set below 70, but it not works. How can I get time respons showing in dasboard too?
    About pulling from the same host I think is not an issue, I tried from localhost and other server as well.
    Thanks Mr. Munroe
     
  10. Mun

    Mun Administrator

    You could try using the firefox network developer tool: https://developer.mozilla.org/en-US/docs/Tools/Network_Monitor

    Go to the uptime script page with it open and see how long it takes.

    [​IMG]

    Mine only takes around ~0.427 seconds

    You can also go to your server and if you have php5-cli installed run it from that.

    Code:
    time php uptime.php
    

    should return something like:

    Code:
    time php uptime.php
    {"uptime":"13 days","memory":"<div class=\"progress progress-striped active\"><div class=\"bar bar-success\" style=\"width: 72%;\">72%<\/div<\/div>","hdd":"<div class=\"progress progress-striped active\"><div class=\"bar bar-success\" style=\"width: 38%;\">38%<\/div<\/div>","load":1.18,"online":"<div class=\"progress\"><div class=\"bar bar-success\" style=\"width: 100%;\"><small>Up<\/small><\/div><\/div>"}
    real  0m0.706s
    user  0m0.052s
    sys  0m0.048s
    
    Where the User / Sys section can show you how long it takes for the script to run.
     
  11. Akmal

    Akmal New Member

    I get 61116 ms from ip xxx.xxx.xxx.27, while other server only take 827 ms :rolleyes:.
     
  12. Mun

    Mun Administrator

    I think it might be to do with the the DW KPA check. Try commenting it out in your code and try again, otherwise it might be an issue with that server. (in any case, that long run time is why it isn't loading.)
     
  13. Akmal

    Akmal New Member

    Excellent Mr. Munroe!
    I created a conditional check about it, because not all server need to check it. And now I turned back time out setting to 10 seconds, and the dashboard working fine.
    Thank you for an awsome support. :)
     
  14. Mun

    Mun Administrator

    Awesome Glad it is working :)
     

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice